Value input in TAlly

Dear Team,

I’m facing an issue with value input in Tally that requires your assistance. When selecting a default value that is not rounded, or manually entering an amount that is not even, the system does not turn the value to green unless it is a round amount. Consequently, I find myself frequently inserting rounded amounts to ensure the entry is accepted.

The challenge intensifies when I need to choose materials with fixed values. I am unable to modify the take-off method or round the amount, making it impossible to define materials due to this rounding and non-rounding issue.

This situation has left me confused and hinders my ability to define the materials I am looking for.

If you have any insights or ideas on how to address this, please share your thoughts.

Thank you all.

Can you provide a screenshot with the issue you’re running into?

Thank you for your response.

Certainly, I have attached a screenshot demonstrating that when selecting a material with a fixed value, it doesn’t turn green. Upon investigation, I discovered that this is due to the value number not being in a rounded form. Consequently, the material remains undefined and appears in red. Unfortunately, I haven’t found a manual workaround or alternative solution. Have you encountered a similar issue?

Hi Nadi,

I tried using the same settings as you did, but on my end Tally doesn’t allow me to change the fixed value - the 4.0904 is greyed out. Attaching what I see on my screen for your reference. Your screen says 4/0904 which I find strange… wonder how that happened. Could it perhaps be a software compatibility issue? I’m using this for Revit 2020, and my Tally version is 2022.04.08.01. (version can be checked under help-about)

Dear Jaein,

thanks for your response. I believe there should be sth wrong with my Revit or Tally version.
I am using Revit 2024, and my Tally version is 2023.09.13.01. As it seems you dont have the same issue that I have.
I have to try different versions.

Thanks alot.

1 Like

I’m still not sure I fully understand the problem, but I do know that Tally doesn’t accept fractions as entries. you have to enter in a decimal number. if you’re worried about rounding errors, Tally’s data appears far more exact than it is. We generally look at the numbers as rough estimates, and that any reductions need to be an order of magnitude +/- to have a potential for actual impact. To give an example - EC3 applies a ~20% uncertainty value to most of their information to account for variations and uncertainty in the EPD data they are pulling in. Tally should probably do the same, but currently doesn’t.

1 Like

Thank you for providing the information.

In the screenshot, the displayed amount is indeed in decimal format. However, I am confused as to why they use “/” as a decimal separator. Regardless, I am confident that the value is in decimal. The issue arises when attempting to input the value; I’ve noticed that fixed values in rounded numbers turn green, while unrounded values like the one shown in the screenshot remain red.
I believe I have to try different version of Tally or Revit.

My guess is that the “/” for the decimal is throwing things off. Tally doesn’t accept “/” in the numbers, which is why rounding to 4 might work, but entering something (and having the decimal switching to “/” ) might break things.

The “/” is unusual. I’m assuming that’s an error either with the tally install or with it working with Revit 2024. Revit 2024 had some major changes to the system that weren’t well coordinated with many of the 3rd party programs, and I wonder if this is an example of that. you might want to reach out to Tally support:

Thank you all for your help.

After uninstall and reinstall my Revit and Tally. I have found that the issue was only with the language of my system settings, not more than this. Thats why it didnt allow me to input numbers in decimal form.

Thanks all for your helps and clarifications